Why aren’t we receiving SMS messages in LiveEngage?

June 18, 2018
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Problem:

We are not receiving SMS messages from some of our clients. This happens inconsistently and sometime we receive only parts of those messages from the clients.

Cause:

Not all LOCAL Twilio numbers (depends on country) support sending SMS messages. The ability of consumers to send SMS messages via these numbers will be partial at best.

Therefore if there are multiple Twilio 30008 errors (or similar) and it looks like a large chunk of SMS messages don’t come into LE form Twilio, chances are the issue is with the type of the phone number.

This can be confirmed by opening a case with Twilio.

Solution:

If the SMS messages that are not received or are partially received have been sent from LOCAL Twilio numbers:

  1. Check whether those numbers support SMS messages (see Twilio international phone number availability and their capabilities).
  2. If your local Twilio numbers do not support SMS,and your mobile numbers do, use mobile lines instead.